В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
KatonAnton
KatonAnton
03.04.2023 15:20 •  Информатика

Напишите программу по выдаче рандомной комбинации букв, соответствующую следующим требованиям: - результат должен состоять из 8 символов (букв)- за буквой a могут стоять только буквы d, e, g, i, jза буквой b только e, f, h, j, kза буквой c только f, g, i, k, lза буквой d только a, g, h, j, lза буквой e только a, b, h, i, kза буквой f только b, c, i, j, lза буквой g только a, c, d, j, kза буквой h только b, d, e, k, lза буквой i только a, c, e, f, lза буквой j только a, b, d, f, gза буквой k только b, c, e, g, hза буквой l только c, d, f, h, i обозначения букв по желанию можно заменить на аналоги (a=а, b=б, c=в, d=г, e=д, f=е, g=ж, h=з, i=и, j=к, k=л, l=м) ​

Показать ответ
Ответ:
Marvarick
Marvarick
20.01.2020 23:14
Для примера со сложением чисел 25 учениками попробуйте проанализировать следующие ситуации: в классе всего 1 кусок мела; в классе 5 кусков мела; в классе 25 кусков мела. оцените, как от этого зависит время решения (учтите ещё ширину доски и время перемещения учеников по классу) попробуйте построить модель такого процесса. переведите эту ситуацию на язык компьютерной терминологии для многопроцессорных систем. 2) попробуйте примеры алгоритмов поиска информации в массиве и сортировки массива, которые допускают распараллеливание операций. опишите процедуру распараллеливания. сколько процессоров необходимо для эффективного распараллеливания в вами примере?
0,0(0 оценок)
Ответ:
evgenijpetrov
evgenijpetrov
08.03.2023 07:22
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
 then writeln('Не квадратное уравнение!')
 else begin
      d:= sqr(b)-4*a*c;
      if d < 0 then writeln('Нет корней')
               else begin
                    x1:= (-b+sqrt(d))/2*a;
                    x2:= (-b-sqrt(d))/2*a;
                    writeln ('X1 =',x1,'  X2 =',x2);
                    end;
      end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота