В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
TamaraKengurs
TamaraKengurs
31.07.2022 06:06 •  Информатика

Напишите программу паскаль. вроде циклы дано натуральное число n. определить, является ли оно совершенным. совершенное число n равно сумме его делителей, не превосходящих само n.

Показать ответ
Ответ:
Direx1337
Direx1337
25.06.2020 15:53
Program gt;
var n,s,l,i:longint;
begin
read(n);
s:=0;
l:=round(sqrt(n));
for i:=1 to l do
begin
if(n mod i=0)then begin
s:=s+i;
s:=s+n div i;
end;
end;
if(l*l=n)then s:=s-l;
if(s<=n)then writeln('ДА ЭТО ПРАВДА')else writeln('НЕТ');
end.
2)
program gt;
var n:integer;
begin
read(n);
if(n=1)then writeln('ДА')else writeln('НЕТ');
end.
3)
program gt;
var n,s:integer;
begin
read(n);
s:=((1+n)*n)div 2;
writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота