В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Evelina0889
Evelina0889
23.01.2020 19:55 •  Информатика

Напишите программу(паскаль) нахождения суммы элементов массива а[1..15], кратных 5 и меньших 50. массив заполняется произвольными числами в диапазоне да 100

Показать ответ
Ответ:
nvanislavskaya
nvanislavskaya
05.10.2020 22:31
Const N = 15;
Var
   A:array[1..N] of integer;
   i:integer;
   S:real;
Begin
S:=0;
Write('Исходный массив: ');
For i:= 1 to N do
    Begin
    A[i]:=random(100);
    Write(A[i],' ');
    if (A[i]<50)and(A[i] mod 5 = 0) then S:=S+A[i];
    End;
WriteLn;
WriteLn('S = ',S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота