В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Nastya23160
Nastya23160
17.09.2022 04:03 •  Информатика

Напишите программу, отображающую n треугольников. n число от 0 до 9​

Показать ответ
Ответ:
ПрофиЗнания
ПрофиЗнания
23.07.2022 20:29
Индекс в нижней части числа означает систему счисления, (...) число в скобках записать внизу(и без скобок):
10111(2) т.е число в двоичной с.с необходимо перевести в 10-ную с.с
10111(2) =23(10)
275(8)=189(10)
1F3(16)=499(10)
112(10)=1110000(2)
если число в 10-ной с.с то 94(10)=136(8), а если число в 16-ричной с.с , то 94 (16)= 224(8)
123(10)= 7В (16)
1110011001(2)=1631(8)
Если в 8-ричной с.с, то 251(8)=10101001(2), если число в 10-ной с.с, то 251(10)=11111011(2), если число в 16-ричной с.с, то 251(16)= 1001010001(2)
1111000(2)= 78(16)
1F5(16)=111110101(2), (буквы I в 16-ричной системе счисления нет)
0,0(0 оценок)
Ответ:
nastasyasaenko
nastasyasaenko
23.06.2022 23:10

1)

program gt1;

var x,y:real;

begin

x:=-3.1;

while x<1 do

begin

x:=x+0.1;

y:=4*x*x*x-2*x*x+5;

writeln(y);

end;

end.

2)

program gt2;

var k,i:integer;

begin

k:=0;

for i:=11 to 20 do

begin

if(i mod 2=1)then k:=k+1;

end;

writeln(k);

end.

3)

program gt3;

var s,i:integer;

begin

s:=0;

for i:=1 to 100 do

begin

if(i mod 2=0)then s:=s+i;

end;

writeln(s);

end.

4)

program gt4;

var sum,a:real;

i,n:integer;

begin

   sum:=0;

   a:=0;

   readln(n);

   for i:=1 to n do begin

   a:=1/((3*n-2)-(3*n+1));

   Sum:=sum + a;

   n:=n+1;

   end;

    write(sum);

end.

5)

program gt5;

var n,k:integer;

begin

k:=0;

while n>0 do

begin

n:=n div 10;

k:=k+1;

end;

writeln(k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота