В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
VovanBah
VovanBah
08.04.2023 10:18 •  Информатика

Напишите программу, определяющую, лежит ли точка а (ха,уа) на прямой y=kx+l, над ней или под ней

Показать ответ
Ответ:
SanchesMaster
SanchesMaster
17.07.2020 22:49
Program a_1;
var xa,ya,y,l,x,k:real;
begin
writeln('введите координаты точки А');
read(xa,ya);
writeln('введите значение коэффициента k и l ');
read(k,l);
if ya=k*xa+l then
begin 
writeln('Точка А принадлежит прямой');
end
else
if ya>k*xa+l then 
begin
writeln('Находится выше прямой');
end
else 
if ya<k*xa+l then
begin
writeln('Находится ниже прямой');
end
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота