Напишите программу нахождения количества и суммы цифр целого положительного числа, используя для этого процедуру Sum(K, C, S), C - количество цифр целого положительного числа K, а S их сумма ( K — входной, C и S — выходные параметры целого типа).
Sample Input 1:
2651
Sample Output 1:
4 14
Sample Input 2:
67557
Sample Output 2:
5 30
Sample Input 3:
84717
Sample Output 3:
5 27
program summa_i_kol_cifr;
var
x,s,k:integer;
begin
read(x);
s:=0;
k:=0;
while x>0 do
begin
s:=s+x mod 10;
k:=k+1;
x:=x div 10;
end;
write(k,' ',s)
end.