В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nastyakolomiec1
nastyakolomiec1
17.04.2021 18:21 •  Информатика

Напишите программу находящую среднее арифметическое четных чисел, вводимых с клавиатуры. решить с цикла с параметром

Показать ответ
Ответ:
EgorUmelii
EgorUmelii
24.07.2020 16:55
Program prl;
uses crt;
var i,n,summa:integer;
      srednee:real;
      a:arra[1..100] of integer;
begin
write('Введите кол-во четных элементов');
readln(n);
summa:=0;
for i:=1 to n do begin
write('Введите ',i,' элемент:'); 
readln(A[i]);
summa:=summa+A[i];
end;
srednee:=summa/(n div 2);
writeln('Среднее арифметическое',srednee:3:2);//
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота