Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
imamverdueffsa
27.03.2020 02:30 •
Информатика
Напишите программу на языке си. придумайте алгоритм, вводящий три целых числа, который находит второе по величине число, если оно существует
Показать ответ
Ответ:
Xzkto666
06.10.2020 01:45
На C++. Если среднее число равно меньшему или максимальному, то выводит No (вариант с "невозможно определить").
#include<iostream>
#include<algorithm>
using namespace std;
int main(){
#pragma waring(disable:4996);
int a,b,c,d;
scanf("%d%d%d",&a,&b,&c);
if(max(a,b) != min(a,b)){
d = max(a,b);
}else{
printf("NO");return 0;
}
if(d > c && c!= min(a,b)){
printf("%d",c);return 0;
}
if( d < c){
printf("%d",d); return 0;
}
printf("NO");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
student87432467
17.02.2022 02:18
С++ Условие Даны два числа N и K. Требуется изменить число N так, чтобы в его двоичном представлении K младших разрядов остались неизменными, а все остальные были...
Kraddy14
29.01.2020 00:16
В этой задаче вам нужно составить алгоритм в виде блок-схемы (программу на языке Python писать не нужно) решения следующих трех задач (три блок-схемы): 1. Даны...
DenKovYa
05.04.2020 09:40
Одноканальный (монофонический) звук оцифрован с частотой 22 кГц. Сколько значений сигнала записано за 5 сек?...
torgor2017
18.01.2021 13:42
Артём заметил, что за 1010 минут до конца контрольной учитель обычно встает из-за стола и начинает ходить между рядами. Значит, можно другу! На очередной контрольной...
Polinakuzmina32
03.10.2022 14:23
1) Изображение было создано с разрешением 150 dpi. Укажите, из скольких пикселей состоит растр, если квадратное изображения имеет размер 4 см на 4 см 2) Укажите...
SkylloutBrain
09.07.2021 03:08
Составить программу, которая запрашивает целые числа до тех пор, пока их сумма не превысит 500. (т.е. после запуска программы пользователя ввести число. Пользователь...
mmaxprophet
10.05.2021 10:38
По данному алгоритму составьте блок-схему: Пример программного алгоритма...
105195hhafhotpb
23.04.2023 19:14
Подобные слагаемые а)3х+ 5х-х= б) 9 y -6х+ х= в)х-5х+9х= г)14а+а-15а= д)-6б+6б+7б= е)-7х+7х-х=...
ubanchikr864roker
23.04.2023 19:14
Саламандра и ящерица эти два животных внешне похожи...
kapysta123
23.04.2023 19:14
Определите стихотворный ! мороз и солнце; день чудесный! еще ты дремлешь, друг прелестный - пора, красавица, проснись: открой сомкнуты негой взоры навстречу северной...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include<iostream>
#include<algorithm>
using namespace std;
int main(){
#pragma waring(disable:4996);
int a,b,c,d;
scanf("%d%d%d",&a,&b,&c);
if(max(a,b) != min(a,b)){
d = max(a,b);
}else{
printf("NO");return 0;
}
if(d > c && c!= min(a,b)){
printf("%d",c);return 0;
}
if( d < c){
printf("%d",d); return 0;
}
printf("NO");
return 0;
}