В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Spy15
Spy15
23.11.2020 09:20 •  Информатика

Напишите программу на языке Scratch который кот проходит к точке 0,100 и потом обратно в точке помагитеее​

Показать ответ
Ответ:
Ален4ик179
Ален4ик179
26.12.2022 11:36
Латинские буквы в кодовых таблицах КОИ-8 и Windows расположены в лексикографическом порядке и имеют одинаковые коды. Цифры и знаки препинания в кодовых таблицах КОИ-8 и Windows имеют различные коды. Русские таблицы в кодовых таблицах КОИ-8 и Windows расположены в порядке возрастания их кодов. Русские таблицы в кодовых таблицах КОИ-8 и Windows расположены в лексико-графическом порядке. Русские таблицы в кодовых таблицах КОИ-8 и Windows имеют различные коды. В кодовых таблицах КОИ-8 и Windows сначала расположены прописные русские буквы, а затем строчные. Русские прописные буквы в кодовых таблицах КОИ-8 и Windows имеют номера со 192 по 223. Русские буквы в кодовых таблицах КОИ-8 и Windows имеют номера со 192 по 225.

Модельный ответ:

Истинные высказывания: 3, 5, 8.

Модельный ответ с подсчетом баллов:

Каждый правильный ответ

Учащийся уложился в 5 минут (при правильном ответе)

Максимальный балл:

Задание №2. Информационная компетентность: Аспект "Первичная обработка информации". Уровень I.

Вам нреобходимо закодировать и раскодировать слова в десятичном и двоичном коде. Пользуясь кодовой таблицей ASCII,

а) закодируйте тексты:

 

 

Текст Десятичный код Двоичный код APPLE     DELETE     MOUSE     7-4=3    

 

б) декодируйте тексты:

Десятичный код Текст 69 78 84 69 82   80 65 73 78 84   66 65 67 75 83 80 65 67 69   Двоичный код Текст 01000101 01001110 01000100   01001000 01001111 01001101 01000101   01010111 01001111 01010010 01000100   01000110 01001111 01001111 01010100 01000010 01000001 01001100 01001100  

 

Модельный ответ:

а):

 

 

Текст Десятичный код Двоичный код APPLE 65 80 80 76 69 01000001 01010000 01010000 01001100 01000101 DELETE 68 69 76 69 84 69 01000100 01000101 01001100 01000101 01010100 01000101 MOUSE 77 79 85 83 69 01001101 01001111 01010101 01010011 01000101 7-4=3 55 45 52 61 51 00110111 00101100 00110100 00111110 00110011

 

б):

 

Десятичный код Текст 69 78 84 69 82 ENTER 80 65 73 78 84 PAINT 66 65 67 75 83 80 65 67 69 BACKSPACE Двоичный код Текст 01000101 01001110 01000100 END 01001000 01001111 01001101 01000101 HOME 01010111 01001111 01010010 01000100 WORD 01000110 01001111 01001111 01010100 01000010 01000001 01001100 01001100 FOOTBALL

 


0,0(0 оценок)
Ответ:
крис897
крис897
28.08.2022 01:34
//Pascal ABC.NET v3.0 сборка 1111

var
 i,a,b:integer;
 ar:array[1..10] of integer;

 procedure oddDec(var a,b:integer);  //подпрограмме переданы аргументы a и b
//процедура для вычитания в нечётном элементе
begin;
a:=a-b;
end;

procedure NotoddInc(var a,b:integer); //подпрограмме переданы аргументы a и b
//процедура для сложения в чётном элементе
begin;
a:=a+b;
end;

begin
randomize;
readln(a); //ввод a
readln(b); //ввод b
writeln('Array:');
for i:=1 to 10 do //весь массив
 begin;
  ar[i]:=random(-20,80); //случайные числа от -20 до 80 включительно
  write(ar[i]:4); //вывод
  if odd(i) then oddDec(ar[i],b) else NotoddInc(ar[i],a);
  {если нечётное, то первая процедура, иначе вторая. Обращаю внимания на то, что элементы меняются сразу после вывода}
 end;
writeln;
writeln('Final array:'); //вывод получившегося массива
for i:=1 to 10 do
write(ar[i]:4);
end.

Пример ввода:
20
10
Пример вывода:
Array:
  10  16   0  60  23   4  22 -20   4  55
Final array:
   0  36 -10  80  13  24  12   0  -6  75  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота