В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vegeg
vegeg
31.05.2023 11:59 •  Информатика

Напишите программу на языке программирования C ++, которая будет реализовывать следующие действия: 1. Требовать ввести 2 целых числа. С цикла отобразите числа от первого введенного до второго введенного и обратно.

2. Требовать ввести 2 целых числа. С цикла отобразите все числа в диапазоне от 1 до 1000, кроме тех, которые делятся без остатка на введенные числа.

3. Отобразите на экране следующие числа с оператора одного цикла:
100,1,99,2,98,3,97,4,…, 51,50
Примечание. Всего должно быть выведено 100 чисел.

Показать ответ
Ответ:
Vika14Veronika
Vika14Veronika
20.02.2021 22:25

#include <iostream>

int main() {

//#1

 int first, last;

 std::cout << "#1\n";

 std::cout << "Input first integer: ";

 std::cin >> first;

 std::cout << "Input last integer: ";

 std::cin >> last;

 for (int i = first; i <= last; ++i)

   std::cout << i << " ";

 std::cout << std::endl;

//#2

 int num1, num2;

 std::cout << "\n#2\n";

 std::cout << "Input first integer: ";

 std::cin >> num1;

 std::cout << "Input second integer: ";

 std::cin >> num2;

 for (int i = 1; i <= 1000; ++i) {

   if (i % num1 == 0 && i % num2 == 0)

     continue;

   std::cout << i << " ";

 }

 std::cout << std::endl;

//#3

 std::cout << "\n#3\n";

 for (int i = 100, j = 1; j <= 50; --i, ++j) {

   std::cout << i << " " << j << " ";

 }

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота