В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
жека0262
жека0262
19.09.2021 22:43 •  Информатика

Напишите программу на языке паскаль. скорость лодки в стоячей воде vл км/ч, скорость течения реки vр км/ч (vр < vл). время движения лодки по озеру т1 ч, а по реке (против течения) — т2 ч. определить путь s, пройденный лодкой. добавлю 10, если будет без ошибок.

Показать ответ
Ответ:
1615005296
1615005296
07.08.2020 20:57
Var v1,v2,t1,t2,s1,s2,so:integer;
begin
v1:=0;
v2:=0;
while (v2>=v1) do begin
 writeln('введите скорость лодки');
 readln(v1);
 writeln('введите скорость течения реки');
 readln(v2);
 if (v2>=v1) then writeln('введены неправильные данные');
 end;
 writeln('введите время движения лодки по озеру');
 readln(t1);
 writeln('введите время движения лодки по реке против течения');
 readln(t2); 
 s1:=v1*t1;
 s2:=(v1-v2)*t2;
 so:=s1+s2;
 writeln('длина общего пути ',so);
end.
0,0(0 оценок)
Ответ:
ehot2004
ehot2004
07.08.2020 20:57
Var vl,vr,t1,t2:real;
begin
  writeln('Скорость лодки в стоячей воде и скорость течения');
  readln (vl,vr);
  writeln('Время движения по озеру и против течения');
  readln (t1,t2);
  writeln('Общий путь судна:', vl*t1+(vl-vr)*t2);
end.

Тестовое решение:
Скорость лодки в стоячей воде и скорость течения
10 3
Время движения по озеру и против течения
2 3
Общий путь судна:41
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота