Напишите программу на языке паскаль которая выводит на экран значение выражения 15i(x+y). Значение целой переменной i и вещественных переменных x, y считываются с клавиатуры.
Var a: array of integer; var i: byte; var b: boolean; begin b: =true; setlength(a,8); var n: =0; writeln('введите число: '); readln(i); var d: =i; while i< > 0 do begin a[n]: =i mod 2; i: =i div 2; inc(n); end; setlength(a,n); for i: =0 to n-1 do begin if n=0 then begin write(0); break; end; swap(a[i],a[n-1]); write(a[i]); end; for i: =1 to n-1 do begin if n=0 then break; if a[i-1]< > a[i] then begin b: =false; break; end; end; if (b=false) then write(' = ',d,' это не палиндром') else write(' = ',d,' это палиндром'); end.
В непосредственном режиме- видимо без ввода программы, ввести последовательно строки (сначала присваиваем значение переменной икс, затем вычисляем выражение и помещаем это значение в переменную игрек, и после печатаем значение переменной игрек):
LET X=1.12
LET Y=SQR (X^3+EXP X-LN (3*X))*(1+4*SIN (X/2)+5*EXP (SIN X))
PRINT Y
И записать результат вычислений, который высветится на экране (у меня получилось 27.839525 но у вас может немного отличаться).
Надеюсь, что в вашей версии бейсика нет отличий от той, что у меня (она весьма старая).
В непосредственном режиме- видимо без ввода программы, ввести последовательно строки (сначала присваиваем значение переменной икс, затем вычисляем выражение и помещаем это значение в переменную игрек, и после печатаем значение переменной игрек):
LET X=1.12
LET Y=SQR (X^3+EXP X-LN (3*X))*(1+4*SIN (X/2)+5*EXP (SIN X))
PRINT Y
И записать результат вычислений, который высветится на экране (у меня получилось 27.839525 но у вас может немного отличаться).
Надеюсь, что в вашей версии бейсика нет отличий от той, что у меня (она весьма старая).