Напишите программу на языке Паскаль, которая вычисляет значение функции y=0, если х меньше или равно 0 y=x, если 0 меньше х меньше или равно 1 y=x², если х больше 1 ХЕЛП ХЛП
Для того, чтобы перевести целое число из десятичной в двоичную систему счисления, необходимо разделить его на два, а затем делить на два каждое полученное частное до тех пор, пока не получится единица. Искомое двоичное число записывается как последовательность цифр, равных последнему частному (единице) и всем полученным остаткам, начиная с последнего.
Надо перевести сначала 21 в двоичную, потом 2 в двоичную и потом 2002 в двоичную
Получается вот так: 21 = 10101 2=10 2002 = 11111010010
+ добавил разницу
Объяснение:
//Программа просит пользователя ввести два числа, получает числа от пользователя>>
//и затем печатает сумму, произведение, разность и частное этих чисел.
#include <iostream>
using namespace std;
int main()
{
int x, y, sum, pr, razn, chastn; //объявление
setlocale(LC_ALL, "Russian"); //руссификация командной строки
cout << "Введите два целых числа через пробел "; //приглашение
cin >> x >> y; //прочитать два целых числа
sum = x + y;
pr = x * y;
razn = x - y;
chastn = x / y;
cout << "Сумма чисел: " << sum << endl << "Произведение чисел: " << pr << endl ;
cout << "Разность чисел: " << razn << endl << "Частное чисел: " << chastn << endl;
_getch();
return 0; //показывает, что программа успешно завершена
}
Надо перевести сначала 21 в двоичную, потом 2 в двоичную и потом 2002 в двоичную
Получается вот так:
21 = 10101
2=10
2002 = 11111010010
В итоге:
10101.10.11111010010