Напишите программу на языке Pascal. Дан целочисленный массив из 5 элементов (значения от 0 до 1000). Найти количество двузначных чисел массива (k=k+1). Буду признательна, если программа будет адаптирована под ввод на компьютере и будет правильно выполняться в приложении Pascal ABC.
begin
var arr := ArrRandomInteger(5, 0, 1000);
arr.Println;
var quantity := 0;
for var i := 0 to arr.Length - 1 do
begin
if (arr[i] > 9) and (arr[i] < 100) then
begin
inc(quantity);
end;
end;
write(quantity);
end.
Объяснение:
begin // Начало программы
var arr := ArrRandomInteger(5, 0, 1000); // Объявление массива размером 5 + заполнение массива случайными значениями из диапазона [0, 1000].
arr.Println; // Вывод массива
var quantity := 0; // Переменная, хранящая количество элементов, равна 0
for var i := 0 to arr.Length - 1 do // Идём от нуля до размера массива - 1
begin // Начало цикла
if (arr[i] > 9) and (arr[i] < 100) then // Если значение массива с индексом i > 9 И < 100, тогда
begin // Начало условного оператора
begin // Начало условного оператора
inc(quantity); // Увеличиваем значение переменной quantity на единицу
end; // Конец условного оператора
end; // Конец цикла
write(quantity); // Выводим ответ
end. // Конец программы