В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sasha524856
sasha524856
03.08.2021 06:28 •  Информатика

Напишите программу, на вход которой подаются отрицательные числа, ввод оканчивается вводом точки. Необходимо найти наименьшее число среди чисел введенной последовательности.

Показать ответ
Ответ:
bozhkosofia
bozhkosofia
03.06.2023 08:59
Формула Шеннона: I=log2 N  (I-кол-во инф-ции; N=всё/нужное)

обозначение:
ч - кол-во четвёрок
т - кол-во троек
д - количество двоек
пятёрок нет

по условию   т+д=22
не провалившиеся = ч+22  > log2 3=log2 ((ч+22)/(ч+т))

инф-ный объём сообщения, что тройка = 2 битам  >
   2=log2 ((ч+22)/т)

Имеем систему трёх уравнений с тремя неизвестными:
т+д=22
log2 3=log2 ((ч+22)/(ч+т))
2=log2 ((ч+22)/т)                                >log2 4=log2 ((ч+22)/т)
       Преобразуем:   
система:
т+д=22
3=(ч+22)/(ч+т)
4=(ч+22)/т        >   ч+22=4т

т+д=22
3ч+3т=ч+22
4т=ч+22

т+д=22
3ч+3т=4т
4т=ч+22

т+д=22
3ч=т
12ч=ч+22

т+д=22
3ч=т
ч=2

ч=2                   т=3ч=6                    д=22-6=16
всего:   2+6+16=24  абитуриента
         ответ  24
0,0(0 оценок)
Ответ:
Pozetiv4ik24
Pozetiv4ik24
10.04.2023 10:56

не так уж и трудно, если

program project2;

var

n,a,b,c,i,k,max,min: longint;

inp,outp: text;

begin

assign(inp,'input.txt');

reset(inp);

assign(outp,'output.txt');

rewrite(outp);

readln(inp,n);

max: =0;

min: =0;

c: =0;

for i: =1 to n do

begin

read(f1,a);

if i=1 then

b: =a;

if a> max then

max: =a;

k: =a-c;

c: =a;

if k< 0 then

begin

k: =abs(k);

min: =min+k;

if k> min then

min: =k;

end;

end;

max: =max-b;

write(outp,max,' ',min);

close(inp);

close(outp);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота