В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
195920
195920
11.02.2023 21:06 •  Информатика

Напишите программу на с++, нужно. вася, петя и коля играли в теннис навылет (проигравший пропускал следующую партию, уступая свое место третьему). вася утверждает, что сыграл x партий, петя – что сыграл y партий, коля – z партий. определите, могло ли такое быть.

Показать ответ
Ответ:
Milky0405
Milky0405
21.08.2020 18:48
Некоторые условияСкорее, главное условие - это чётность игр. Поскольку в партии играет по двое, то сумма чисел должна быть чётной. Код

#include <iostream>

using namespace std;

int main()

{

   unsigned int x, y, z;

   cin >> x >> y >> z;

   if((x + y + z) % 2 == 0){

       if((3*z + 2 >= x + y) || (3 * x + 2 >= y + z) || (3 * y + 2 >= x + z)){

           cout << "YES";

           return 0;

       }

   }

   else{

       cout << "NO";

       return 0;

   }

   return 0;

}

Проверка

2 2 2                                                                                                

YES

3 1 2                                                                                                

YES

1 1 1                                                                                                

NO

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота