В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
solnisko22
solnisko22
07.10.2022 03:05 •  Информатика

Напишите программу на с++, которая вводит натуральное число n и выводит на экран все натуральные числы, не превосходящие n и делящуеся на каждую из своих цифр

Показать ответ
Ответ:
ivanovmax
ivanovmax
08.10.2020 00:50
#include <bits/stdc++.h>

using namespace std;

int main()
{
   int n; cin >> n;
   for (int i = 1; i <= n; ++i)
   {
       int tmp = i;
       bool fl = true;
       while (tmp) {
            int x = tmp % 10;
             if (x != 0)
                if (i % x != 0)
                  fl = false;
              if (!x) fl = false;
            tmp /= 10;
       }
       if (fl) cout << i << ' ';
   }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота