В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Артемsly
Артемsly
19.05.2021 03:28 •  Информатика

Напишите программу на С Дана целочисленная прямоугольная матрица. Определить:
а) количество строк, не содержащих ни одного нулевого элемента;
б) максимальное из чисел, встречающихся в заданной матрице
более одного раза.
ещё нужно скрины работы программы

Показать ответ
Ответ:
annaerkina
annaerkina
15.10.2020 10:16

а)

#include <iostream>

#include <vector>

using namespace std;

bool is_any_nulls(vector<int> vec){

   for(int i: vec)

       if(i == 0)

           return true;

   return false;

}

signed main() {

   int n,m;

   cin >> n >> m;

   vector<vector<int>> a(n);

   for(int i = 0; i < n; i++){

       vector<int> temp(m);

       for(int &j: temp)

           cin >> j;

       a[i] = temp;

   }

   int cnt = 0;

   for(vector<int> i: a)

       if(!is_any_nulls(i))

           cnt++;

   cout << cnt;

}

б)

#include <iostream>

#include <vector>

#include <map>

using namespace std;

signed main() {

   int n, m;

   cin >> n >> m;

   map<int,int> mp;

   vector<vector<int>> a(n);

   for (int i = 0; i < n; i++) {

       vector<int> temp(m);

       for (int &j: temp){

           cin >> j;

           mp[j]++;

       }

       a[i] = temp;

   }

   int mx = -INT_MAX;

   for(auto i: mp)

       if(i.first > mx && i.second > 1)

           mx = i.first;

   cout << mx;    

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота