В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Напишите программу на pyton ( ) Компания Microsony выпустила на рынок новую революционную игровую приставку BoxStation, и число желающих приобрести её огромно!

В день открытия продаж в магазин пришло N покупателей. Видя ажиотажный спрос, администрация договорилась, что в день открытия продаж в магазин поступят M приставок, и в последующие дни также будут подвозиться по M приставок ежедневно. Нераспроданные приставки остаются на складе в магазине и могут быть реализованы позже.

Однако спрос на приставки оказался столь велик, что на второй день в магазин за приставками пришли N + 1 покупателей, на третий день — N + 2 покупателей и далее в каждый день покупателей было ровно на 1 больше, чем в предыдущий день. Каждому покупателю отпускается одна приставка. Но контракт с поставщиками приставок уже заключён, поэтому несмотря на рост спроса в магазин всё равно ежедневно привозят только M новых приставок.

Определите, в какой день магазину не хватит приставок для того, чтобы удовлетворить запросы всех покупателей.

Входные данные
Первая строка входных данных содержит целое число N (1 ≤ N ≤ 109) — количество покупателей в первый день продаж. Вторая строка входных данных содержит целое число M (1 ≤ M ≤ 109) — количество ежеднево поставляемых в магазин приставок.

Выходные данные
Программа должна вывести одно целое число — номер дня, в который число покупателей в магазине превысит число доступных приставок.

Система оценки
Решения, правильно работающие, когда входные числа не превосходят 100, будут оцениваться в

Пример
Ввод

Вывод

Пояснение

10
12

6

В первый день в магазин привезли 12 приставок, а пришло 10 покупателей, в конце дня в магазине осталось 2 приставки. На второй день привезли ещё 12 приставок, из них купили 11, поэтому в магазине осталось 2+12-11=3 приставки. На третий день привезли 12 приставок и пришло 12 покупателей, поэтому в магазине также осталось 3 приставки. На четвёртый день привезли 12 приставок, а купили 13, поэтому в магазине осталось 3+12-13=2 приставки. На пятый день привезли 12 приставок, а купили 14, поэтому в магазине не осталось ни одной приставки. Поэтому на шестой день магазин не сможет удовлетворить всех покупателей.

Показать ответ
Ответ:
человек416
человек416
20.12.2021 15:10

ответ (Python):

b = int(input())

a = int(input())

left = 0

right = 2 * 10 ** 9 + 1

while right - left > 1:

   mid = (left + right) // 2

   plus = a * mid

   minus = (b + b + mid - 1) * mid // 2

   if plus >= minus:

       left = mid

   else:

       right = mid

print(right)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота