Напишите программу на python
Выдача сдачи — 2
Имеется неограниченное количество монет в 1, 2, 5, 10 рублей. Определите, сколькими можно выдать сдачу в n рублей. Например, 5 рублей можно выдать четырьмя Входные данные
Программа получает на вход натуральное число n, не превышающее 106.
Выходные данные
Выведите ответ на задачу.
Примечание
Правильное решение задачи можно написать, используя всего один цикл while.
Примеры
Ввод
Вывод
2
2
100000
1667116705001
begin
var a:=ArrRandom(100,-10,10);
a.Println;
Writeln(a.Where(x->x>0).Count,' положительных, ',
a.Where(x->x<0).Count,' отрицательных')
end.
Тестовое решение:
4 -6 0 8 2 -2 -1 -8 -6 8 -3 7 4 -7 -5 9 0 -3 -7 1 0 -4 6 3 8 -10 4 9 3 5 8 5 5 8 10 4 -8 3 8 8 -9 2 7 -8 -7 -5 2 -9 0 9 -7 7 -2 -6 7 -2 -1 7 -10 2 4 1 -1 0 10 3 -8 6 -6 2 6 7 -1 -4 -1 8 0 3 0 2 -2 2 -1 5 1 -9 -4 1 -9 1 -6 -5 3 -4 -7 1 -7 -3 -7 1
51 положительных, 42 отрицательных
ответ:Многие страны перешли на т.н. «информационное общество», некоторые – в процессе перехода, в зависимости от факторов, влияющих на то или иное население. Все меньше уделяется внимания печатным изданиям: ученные говорят о том, что лет через 30 газеты, журналы, книги исчезнут с прилавков.
С одной стороны, электронные страницы – это хорошо, меньше вреда наносится окружающей среде, да и хранить большое количество информации легче и удобнее в электронном виде. С другой стороны – человечество становится все более зависимым от техники.