В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
svetlana898
svetlana898
25.01.2020 14:31 •  Информатика

Напишите программу на Python
Список квадратов
Дано число N. Выведите N квадратов чисел от 1 до N (включительно) в формате [1, 4, 9, 16,…, N**2]. Используйте функцию print() для вывода списка.

Входные данные:

В одной строчке дано натуральное число N≤200.

Выходные данные:

Список квадратов в указанном формате.

Показать ответ
Ответ:
Даня1221
Даня1221
24.08.2020 22:04

N = int(input())

arr = [0] * N

for i in range(1,N + 1):

   arr[i - 1] = i ** 2

print(arr)

1 строка - ввод числа N

2 строка - создание массива на N элементов, заполненных нулями

3 строка - цикл на N шагов, где i будет изменяться от 1 до N включительно

4 строка - массивы нумеруются с 0, так что i - 1. Заполнение массива квадратами

5 строка - вывод. Если вывести массив такой командой, то он выведется в нужном формате

0,0(0 оценок)
Ответ:
Deiselpro1
Deiselpro1
24.08.2020 22:04

N = int(input())

print([i**2 for i in range(1, N+1)])

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота