В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Петя1134
Петя1134
01.03.2020 02:49 •  Информатика

Напишите программу на Python по 22-ой задачи ЕГЭ.
Нужна именно программа У исполнителя Калькулятор три команды, которым присвоены номера:

прибавь 1
умножь на 2
возведи в квадрат
Сколько есть программ, которые число 2 преобразуют в число 38?

Показать ответ
Ответ:
lisablida
lisablida
11.10.2020 20:23

Создадим список a. В a[k] будем хранить количество различных программ, по которым Калькулятор может получить из 2 число k.

При небольших k зададим значения вручную: a[0] = a[1] = 0; a[2] = 1 (для k = 2 удобно считать, что есть одна программа - пустая).

Для k > 2 можно вычислять a[k] так: a[k] = a[k - 1] + a[k/2] * {k - полный квадрат} + a[sqrt(k)] * {k - полный квадрат}. Здесь {P} - 1, если P верно, и 0, если ложно.

По описанию программа составляется просто (версия питона 3.8, в ней появилась функция isqrt, если у вас python3, но версия меньше 3.8, можете округлить корень для ближайшего целого):

from math import isqrt

a = [0] * 39

a[2] = 1

for k in range(3, 39):

 a[k] = a[k - 1]

 if k % 2 == 0:

   a[k] += a[k // 2]

 t = isqrt(k)

 if t ** 2 == k:

   a[k] += a[t]

 print(f"{k:3} {a[k]:5}")

Программа выводит все промежуточные ответы и a[38]

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота