В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vikula2404
Vikula2404
29.10.2022 21:43 •  Информатика

Напишите программу на Python.
"Найти количество четных цифр заданного натурального числа N."

Показать ответ
Ответ:
dostovalovaanast
dostovalovaanast
27.02.2021 19:20

while True:

 try:

   n = int(input('Введите натуральное число: '))

   break

 except ValueError:

   print('Неверные входные данные. Попробуйте снова.')

n = abs(n)

b = 0

while n>0:

 if n%10%2 == 0:

   b+=1

 n = n//10

print('Количество чётных цифр в ведённом числе равно ' + str(b))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота