В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Mashka063
Mashka063
24.06.2020 16:18 •  Информатика

Напишите программу на Python, которая ищет среди целых чисел, принадлежащих числовому отрезку [1024; 28921], числа, которые делятся на сумму всех своих цифр. Запишите в ответе сумму всех таких чисел. Например, в диапазоне [12; 20] есть следующие числа: 12,18,20. Поэтому
для этого диапазона ответом является 12+18+20=50.

Показать ответ
Ответ:
CasDavis
CasDavis
18.07.2021 19:00

def delitel(n):

   summa=0

   while n:

       summa+=n%10

       n//=10

   return summa

summa=0

for i in range(1024,28922):

   if i%delitel(i)==0:

       summa+=i

print(summa)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота