В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kovitidi2002
kovitidi2002
31.01.2022 07:42 •  Информатика

Напишите программу на python даны два четырехзначных числа а и в. выведите в порядке возрастания все четырехзначные числа в интервале от а до в,запись которых содержит ровно три одинаковые цифры входные данные-1900; 2100 выходные данные-1911; 1999; 2000; 2022

Показать ответ
Ответ:
nurik1238910
nurik1238910
03.10.2020 11:22
a = int(input())
b = int(input())
while a < b:
   for i in range(10):
       if 3 == str(a).count(str(i)):      
       print(a)
a += 1

Тест №1
1900
2100

1911
1999
2000
2022

Тест №2
4999
5222

4999
5000
5055
5111
5155
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота