В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dppfpffpfp
dppfpffpfp
29.05.2021 23:37 •  Информатика

Напишите программу на питоне, . программа получает на вход строку и символ. используя метод напишите программу, которая выводит все позиции, где встречается этот символ.

Показать ответ
Ответ:
ghaban
ghaban
20.08.2020 15:36
S = input('Строка: ')
c = input('Символ: ')[0]
o = []
p = 0
while True:
    r = s.find(c, p)
    if r == -1:
        break
    else:
        o.append(str(r))
        p = r + 1
print('Позиции:', ', '.join(o))
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота