В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Mara1111176
Mara1111176
09.05.2021 19:14 •  Информатика

Напишите программу(на питоне), которая определяет, попала ли точка с заданными координатами в заштрихованную область.
входные данные
входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x -координата, затем – y -координата).

выходные данные
программа должна вывести слово 'yes', если точка попала в заштрихованную область, и слово 'no', если не попала.

Показать ответ
Ответ:
POLINAFLY
POLINAFLY
16.08.2020 21:17

program tochka;  

var x,y:real;

begin

writeln('Input x,y');

read(x,y);

if (x*x+y*y>4) and (y<x) and (x<2) then writeln ('YES')

else  

writeln('NO');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота