В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AZIMJON11
AZIMJON11
25.12.2022 12:26 •  Информатика

Напишите программу НА ПИТОНЕ, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число — сумму чисел, кратных 3 и не кратных 6, встречающихся в последовательности.

Показать ответ
Ответ:
аннасерб
аннасерб
04.02.2021 22:00

summ, count = 0,0

while 1:

   a = int(input())

   if count == 1000:

       print("Кол-во чисел 1000")

       break

   elif a > 30000:

       print("Число больше 30.000")

       count -= 1

   elif a == 0:

       break

   elif a % 3 == 0 and a % 6 != 0:

       summ += a

   count += 1

print(summ)


Напишите программу НА ПИТОНЕ, которая находит количество чисел, кратных 3, но не кратных 6, в послед
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота