В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
KarinaDelacour
KarinaDelacour
19.02.2021 13:36 •  Информатика

Напишите программу на питоне или скажите как решать. Рассматриваются целые числа, принадлежащих числовому отрезку [416782; 498324], которые представляют собой произведение трёх различных простых делителей, оканчивающихся на одну и ту же цифру. В ответе запишите количество таких чисел и разницу между максимальным и минимальным из них.

Показать ответ
Ответ:
AfinaBi
AfinaBi
29.03.2023 13:20

program expression;

var

 x, y: real;

begin

 read(x);

 y := power(x, 4) - 3 * power(x, 3) + 5 * x - 6;

 write(y);

end.

Объяснение:

program expression;  // Название программы

var

 x, y: real;  // Две переменные являются вещественными (требуется для power)

begin  // Начало программы

 read(x);  // Вводим число с клавиатуры

 y := power(x, 4) - 3 * power(x, 3) + 5 * x - 6;  // Само выражение

power(число, которое нужно возвести в степень | сама степень)

power(x, 4)

x - число

4 - степень

 write(y);  // Выводим ответ

end. // Начало программы

0,0(0 оценок)
Ответ:
Violetta1508mailru
Violetta1508mailru
14.04.2023 07:50

a = [1, 100, 10, 2]

a = sorted(a, reverse=True)

if (len(a) > 2):

 if(a[0] != a[1] and a[1] != a[2]):

   print(a[1])

 else:

   print(0)

else:

 print(0)

Объяснение:

Итак, как я понял, абсолютный минимум и максимум это самый большой и самый маленький элемент в списке, значит нам нужно вывести второй по величине. Сортируем массив с sorted(значит мы сортируем массив и записываем результат в a, заменяя старый), причем сортируем с reverse=True так как по умолчанию он сортирует по возрастанию, а нам нужно по убыванию. Затем мы проверяем длинну списка и если в ней есть хотя бы 3 элемента(0, 1, 2 - абсолютный максимум, искомый элемент и абсолютный минимум), то выводим искомый элемент(второй элемент списка, индекс у него 1 так как счет с 0), иначе выводим 0

upd: вложенный if сравнивает первый и второй и второй и третий элементы. Если они равны, то тоже выводим ноль

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота