В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Artemhhh
Artemhhh
12.03.2020 10:15 •  Информатика

Напишите программу на паскале: Сгенерируйте целочисленный массив из 20 элементов случайным образом в диапозоне от -15 до 15. Посчитайте сумму элементов которые больше 9; Посчитайте сумму четных элементов

Показать ответ
Ответ:
Сmetana34
Сmetana34
16.09.2021 02:45

с++

#include <iostream>

#include <ctime>

using namespace std;

int main() {

srand(time(NULL));

int arr[10],sum=0;

for (int i = 0; i < 10; i++) //заполнение массива  

{

 arr[i] = rand() % 100;

}

for (int i = 0; i < 10; i++) //вывод массива

{

 cout << arr[i] << "\t";

}

cout << endl;

for (int i = 0; i < 10; i++) //узнаем кратность чисел

{

 if (arr[i] % 4 == 0) {

  sum = sum + arr[i];

 }

}

cout << sum << endl;

 system("pause");

 return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
AirinMandarin
AirinMandarin
07.09.2020 18:09
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
const
  n=5;
type
  Matrix=array[1..n,1..n] of integer;

procedure DummySchool(var a:Matrix);
begin
  Writeln('Ввод элементов матрицы');
  for var i:=1 to n do begin
    Write(n,' элементов строки ',i,': ');
    for var j:=1 to n do Read(a[i,j]);
    end;
  Writeln('Сформирована матрица ',n,'x',n);
  for var i:=1 to n do begin
    for var j:=1 to n do Write(a[i,j]:5);
    Writeln
    end
end;

begin
  var B:Matrix;
  DummySchool(B);
  var sn:=0;
  var sp:=0;
  for var i:=1 to n do
    for var j:=1 to n do
      if B[i,j]<0 then sn+=B[i,j]
      else
        if B[i,j]>0 then sp+=B[i,j];
  Writeln('Сумма отрицательных ',sn);
  Writeln('Сумма положительных ',sp)
end.

Тестовое решение:
Ввод элементов матрицы
5 элементов строки 1: 6 23 -5 13 9
5 элементов строки 2: 42 0 -38 16 37
5 элементов строки 3: -5 -18 3 11 8
5 элементов строки 4: 9 13 -11 0 3
5 элементов строки 5: 19 -17 0 15 5
Сформирована матрица 5x5
    6   23   -5   13    9
   42    0  -38   16   37
   -5  -18    3   11    8
    9   13  -11    0    3
   19  -17    0   15    5
Сумма отрицательных -94
Сумма положительных 232
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота