В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dizzone
dizzone
15.09.2022 09:35 •  Информатика

Напишите программу на паскале, которая в последовательности натуральных чисел определяет
количество чисел, кратных 7. Программа получает на вход количество чисел в
последовательности, а затем сами числа. В последовательности всегда имеется число,кратное 7. ( while или repeat)

Показать ответ
Ответ:
Angelaby
Angelaby
21.04.2021 18:20

var a:array[1..1000] of integer;  

sum,n,i:integer;  

begin  

sum:=0;  

writeln('Введите количество чисел');  

read(n);  

writeln('Введите числа');  

for i:=1 to n do begin  

read(a[i]);  

if (a[i] mod 7=0) and (a[i] mod 10=4)then sum:=sum+a[i];  

end;  

writeln('Сумма элементов кратных 7 и оканчиваюшихся на 4 = ',sum);  

end.

Объяснение:

пойдет?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота