В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
pavelstanowkin
pavelstanowkin
21.03.2021 02:12 •  Информатика

Напишите программу на паскале. дан массив положительных и отрицательных чисел. вычислить сумму положительных и произведение отрицательных чисел. а[1..10]

Показать ответ
Ответ:
ekaterinaparsh1
ekaterinaparsh1
02.10.2020 14:05
Const m=10;
var
a:array[1..m] of integer;
i,sum,proz:integer;
begin
sum:=0;
proz:=1;
for i:=1 to m do
begin
read(a[i]);
if a[i]>0 then
sum:=sum+a[i]
else
ifa[i]<0 then
proz:=proz*a[i];
end;
writeln('Сумма положительных чисел= ',sum,' Произведение отрицательных чисел= ',proz);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота