В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Sergant17
Sergant17
18.11.2020 15:54 •  Информатика

Напишите программу на java Напишите новый метод класса Point с названием scale, который сделает точку наполовину ближе к началу координат (0,0). Например, точка с координатами (8, 4) после выполнения метода scale будет иметь координаты (4, 2).

Показать ответ
Ответ:
vinerplay6
vinerplay6
25.08.2020 14:43

Описание алгоритма:

Будем наращивать длину последовательности от 0 знаков до N. Пусть после какого-то количества шагов у нас выписаны все последовательности длины А и мы хотим узнать количество подходящих последовательностей длины А+1. Распределим все последовательности на три группы(так как предыдущие символы нас не волнуют, то любые последовательности одной группы для нас равнозначны):

1) Заканчиваются на 0.

2) Ровно на одну единицу

3) Ровно на две единицы.

Из каждой последовательности группы 1 приписыванием нуля или единицы мы можем получить одну последовательность группы 1 и одну - группы 2. Неважно, какие именно, но они не перекрываются, т.к. предыдущие символы различны, хоть мы их и не учитываем. Точно так же из второй группы мы получаем одну последовательность группы 3 и одну группы 1, а из группы 3 - только группу 1. Таким образом, если количества последовательностей длины А по группам были (x, y, z), то для длины А+1 такое распределение будет (x+y+z, x, y). Если взять для длины 0 тройку (0, 0, 1) и просчитать тройки от 1 до N, получится искомое количество. Для a=1 и b=2 также работает правильно.

Программа на Pascal:

var num00,num01,num11,mem00:integer;

   a,i:byte;

begin

readln(b);

 num00:=1;

 for i:=1 to n do begin

   mem00:=num11;

   num11:=num01;

   num01:=num00;

   num00:=num01+num11+mem00;

 end;

writeln(num11+num01+num00);

end.

Объяснение:

извени если ошебусь

:)

0,0(0 оценок)
Ответ:
Артур15051505
Артур15051505
20.07.2020 18:18

Если я правильно понял, то

1. Вариант С++

#include <iostream>


int NOD(int var1, int var2) //Алгоритм Евклида

{

   while(var1 != var2)

   {

       if(var1 > var2)

           var1 = var1 - var2;

       else var2 = var2 - var1;

   }

   return var1;

}

int NOK(int var1, int var2)

{

   return (var1 * var2) / NOD(var1, var2);

}

int main()

{

   short int

       a, b, c, d,

       m, n, NK;

   std::cin >> a >> b >> c >> d;


   NK = NOK(b, d); // избегаем не нужных вычислений

   m = a * (NK / b) + c * (NK / d);

   n = NOK(b, d);


   std::cout << "Первая дробь: " << a << "/" << b << std::endl;

   std::cout << "Вторая дробь: " << c << "/" << d << std::endl;


   std::cout << std::endl << "Результат: " << m << "/" << n << std::endl;


}

2. C

#include <stdio.h>


int NOD(int var1, int var2) //Алгоритм Евклида

{

   while(var1 != var2)

   {

       if(var1 > var2)

           var1 = var1 - var2;

       else var2 = var2 - var1;

   }

   return var1;

}

int NOK(int var1, int var2)

{

   return (var1 * var2) / NOD(var1, var2);

}

int main()

{

   short int

       a, b, c, d,

       m, n, NK;

   scanf("%hi%hi%hi%hi", &a, &b, &c, &d);


   NK = NOK(b, d); // избегаем не нужных вычислений

   m = a * (NK / b) + c * (NK / d);

   n = NOK(b, d);


   printf("Первая дробь: %hi/%d\n", a, b);

   printf("Вторая дробь: %hi/%d\n", c, d);


   printf("Результат: %hi/%hi\n", m, n);


}


Даны две рациональные дроби: a/b и c/d. сложите их и результат представьте в виде несократимой дроби
Даны две рациональные дроби: a/b и c/d. сложите их и результат представьте в виде несократимой дроби
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота