В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DanyNeifeld
DanyNeifeld
21.09.2020 16:13 •  Информатика

Напишите программу на C# Дан массив целых чисел. Выяснить:
а) является ли s-й элемент массива положительным числом;
б) является ли k-й элемент массива четным числом;
в) какой элемент массива больше: k-й или s-й

Показать ответ
Ответ:
бббб9
бббб9
08.09.2022 04:35

1. Переменная – это «именованное хранилище» для данных. Мы можем использовать переменные для хранения товаров, посетителей и других данных.

2.Трансля́тор — программа или техническое средство, выполняющее трансляцию программы. Трансля́ция програ́ммы — преобразование программы, представленной на одном из языков программирования, в программу на другом языке. ... Выходной язык называется целевым языком.

3.Язы́к программи́рования — формальный язык, предназначенный для записи компьютерных программ[1][2]. Язык программирования определяет набор лексических, синтаксических и семантических правил, определяющих внешний вид программы и действия, которые выполнит исполнитель (обычно — ЭВМ) под её управлением.

:)

0,0(0 оценок)
Ответ:
ДаняКашин
ДаняКашин
22.08.2022 13:26

ЯП: С++ | можно не писать std:: , если использовать пространство имен: using namespace std;

#include <iostream>

int main() {

const int SIZE = 10;

int regim, sum, max, count;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 std::cin >> arr[i]; // вводим элементы массива

 std::cout << arr[i] << "\t"; // выводим массив в консоль

}

std::cin >> regim;

if ((regim > 0) && (regim < 4))

{

 if (regim == 1)

 {

  for (int i = 0; i < SIZE; i++)

  {

   sum += arr[i]; // или sum = sum + arr[i];

  }

  std::cout << "Сумма элементов массива = " << sum << std::endl;

 }

 else if (regim == 2)

 {

  max = arr[0];

  for (int i = 0; i < SIZE; i++)

  {

   if (max < arr[i])

    max = arr[i];

  }

  std::cout << "Максимальный элемент в массиве = " << max << std::endl;

 }

 else

 {

  for (int i = 0; i < SIZE; i++)

  {

   if (arr[i] < 0)

    count++;

  }

  std::cout << "Число отрицательных элементов в массиве = " << count << std::endl;

 }

}

else

 std::cout << "Доступен только 1-3 режим!" << std::endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота