В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Temka333333
Temka333333
03.02.2022 04:48 •  Информатика

Напишите программу на C ++, чтобы найти третий угол треугольника. Введите 1-й угол треугольника: 30
Введите 2-й угол треугольника: 60​

Показать ответ
Ответ:

#include<iostream>

#include<iomanip>

#define _USE_MATH_DEFINES

#include<cmath>

using namespace std;

 

int main()

{

   double a, b, c, alfa, beta, gamma;

   

   cout <<"a="; cin >> a;

   cout <<"b="; cin >> b;

   cout <<"c="; cin >> c;

   

   if (a+b>c && a+c>b && b+c>a)

   {    

   alfa = acos((b*b+c*c-a*a)/(2*b*c))*180/M_PI;

   beta = acos((a*a+c*c-b*b)/(2*a*c))*180/M_PI;

   gamma = acos((a*a+b*b-c*c)/(2*a*b))*180/M_PI;    

   cout <<"Angles in degrees:\n";

   cout <<setprecision(3)<<fixed<< "alfa=" << alfa << " beta=" << beta << " gamma=" << gamma << endl;

   }

   else cout << "Triangle absent\n";

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота