В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
tabita5r
tabita5r
05.04.2022 23:33 •  Информатика

Напишите программу на алгоритмическом языке, нарисуйте блок-схему и постройке трассировочную таблицу для следующего задания. 1. Определить количество чисел, которые делятся на 4, из натурального ряда от А до В.
2. Принадлежит ли точка с координатами (x,y) закрашенной области

надо​


Напишите программу на алгоритмическом языке, нарисуйте блок-схему и постройке трассировочную таблицу

Показать ответ
Ответ:
Полиняша
Полиняша
06.03.2020 14:58

const

 n=5;

type

 st = array [1..n] of integer;

var

 a:array [1..n] of st;

 b:st;

 i,j,maxp:integer;

 

begin

 for i:=1 to n do

   begin

     b[i]:=1;

     for j:=1 to n do

       begin    

         a[j,i]:=random(20)+1;

         b[i]:=b[i]*a[j,i];

       end;

   end;

 maxp:=0;  

 for i:=1 to n do

   begin

     for j:=1 to n do

       begin

         write(a[i,j]:4);

         if i+j>n+1 then

           if a[i,j]>maxp then

             begin

               maxp:=a[i,j];

             end;

       end;

     writeln;

   end;

 writeln;

 writeln('Максимальное под побочной диагональю: ',maxp);

 for i:= 1 to n do

   write(b[i],' ');

end.

0,0(0 оценок)
Ответ:
mashazygmangovich
mashazygmangovich
11.04.2022 20:34

A and B = 01010010 = 82

Объяснение:

Для начала представим в виде битовой строки

А OR B = 87 = 01010111

А XOR B = 5 = 00000101

XOR дает логическую единицу если исходные данные различаются и ноль, если одинаковые. Значит у A и B только нулевой и второй (если считать справа) биты разные. То есть

A = 1x1

B = 0x0

В данном случае без разницы у кого будет 1, а у кого ноль, потому как нам нужно будет узнать их логическое И, которое от перестановки не меняется.

Далее опираемся на логические единицы в побитовом ИЛИ, то есть биты, которые стали логической единицей будут ей же в исходных A и B, нули соответственно тоже. Итого получаем.

A = 01010111

B = 01010010

Теперь побитово считаем И

A and B = 01010010 = 82

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота