В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
simkinaalinoschka
simkinaalinoschka
28.09.2021 05:56 •  Информатика

Напишите программу: мальчик саша учится в школе ш, одна из особенностей которой состоит в том что на уроках в ней ставят только двойки и пятёрки. саша заранее узнал, на каких уроках языка он получит 2, а на каких — 5. саша идёт на деревянную медаль, и поэтому ему надо получить оценку за год не ниже 4 (четвёрка ставится, если хотя бы половина оценок — пятёрки, и при этом есть хотя бы одна оценка). он хочет прогулять часть уроков, чтобы исправить ситуацию (если саша прогуливает урок, он не получает никакой оценки). но саша — добропорядочный мальчик, поэтому он хочет прогулять минимальное количество уроков. ему.

Показать ответ
Ответ:
ju1227
ju1227
04.10.2020 04:41
//Dev-C++ 5.11 (C)

#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>

int main(void)
 {int n,mark,count2=0,count5=0,res;
 printf("Enter number of classes:");
 scanf("%d",&n);
 printf("Enter marks:\n");
 for(int i=0;i<n;i++)
 {scanf("%d",&mark);
 if(mark==5) count5++;
    if(mark==2)
     count2++;}
    res=count2-count5;
    if (res<0)
  res=0;
    if (count5==0)
  printf("Impossible");
 else
  printf("%d",res);
 return 0;}

Пример ввода:
3
5
2
2
Пример вывода:
1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота