напишите программу которая запрашивает значение двух целочисленных переменных на одной строке, а на другой выводит сообщение результат деления переменных =*** ответ должен быть с тремя цифрами в дробной части
var arr : arr2; n : integer; i, sot, spl, snu : byte; ch : char;
begin write('Хотите использовать заданный по умолчанию массив? (y/n): '); ch := readkey; writeln(ch); sot := 0; spl := 0; snu := 0; if ((ch='y') or (ch='Y')) then begin { Используем заданный по умолчанию } for i:=1 to 12 do begin if arr1[i] > 0 then inc(spl); if arr1[i] < 0 then inc(sot); if arr1[i] = 0 then inc(snu); write(arr1[i], ' '); end; writeln; end else begin { Создаём и заполняем новый массив } write('Введите желаемый размер массива: '); readln(n); setLength(arr, n); writeln('Введите элементы массива:'); for i:=0 to high(arr) do readln(arr[i]); for i:=0 to high(arr) do begin if arr[i]>0 then inc(spl); if arr[i]<0 then inc(sot); if arr[i]=0 then inc(snu); write(arr[i], ' '); end; writeln; end;
7)На координатной плоскости отмечены числа p,q и r.
Какая из разностей q-p, q-r, r-p отрицательная.
ответ: q-r такая из разниц будет отрицательная
8)
9)
х=±7
ответ :-7
10) Костя не выучил 4 билета всего 25 билетов
25-4=21
Вероятность что Кости попадется билет который он знает 21/25=0,84
13) 8х-3(х+9)≥-9
8х-3х-27≥-9
8х-3х≥-9+27
5х≥18
х≥18/15
х≥3,6
ответ: [3,6;∞) №1
14) 1 минута образуется осадок 0,2 грамма
а1=0,2 гр
а7= неизвестная переменная
d = 0,5 - на столько каждую минуту увеличивается масса осадка.
Формула n-ого члена арифметической прогрессии выглядит так:
аn = a1 + d(n - 1).
Подставляем данные величины:
а7 = 0,2 + 0,2(7 - 1) = 0,2 + 1,2= 1,4грамма
ответ: 1,4 грамма
Объяснение:
program pr1;
uses
crt;
const
arr1 : array[1..12] of integer = (5, 4, -3, 1, 0, -4, 0, 25, -8, 0, -17, -1);
type
arr2 = array of integer;
var
arr : arr2;
n : integer;
i, sot, spl, snu : byte;
ch : char;
begin
write('Хотите использовать заданный по умолчанию массив? (y/n): ');
ch := readkey;
writeln(ch);
sot := 0;
spl := 0;
snu := 0;
if ((ch='y') or (ch='Y')) then begin
{ Используем заданный по умолчанию }
for i:=1 to 12 do begin
if arr1[i] > 0 then inc(spl);
if arr1[i] < 0 then inc(sot);
if arr1[i] = 0 then inc(snu);
write(arr1[i], ' ');
end;
writeln;
end
else begin
{ Создаём и заполняем новый массив }
write('Введите желаемый размер массива: ');
readln(n);
setLength(arr, n);
writeln('Введите элементы массива:');
for i:=0 to high(arr) do
readln(arr[i]);
for i:=0 to high(arr) do begin
if arr[i]>0 then inc(spl);
if arr[i]<0 then inc(sot);
if arr[i]=0 then inc(snu);
write(arr[i], ' ');
end;
writeln;
end;
writeln('Количество отрицательных элементов: ', sot);
writeln('Количество нулевых элементов: ', snu);
writeln('Количество положительных элементов: ', spl);
end.