В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
yaroslavaaf
yaroslavaaf
16.12.2022 10:00 •  Информатика

. Напишите программу, которая запрашивает координату точки на числовой оси и выдаёт TRUE, если точка принадлежит заштрихованной области и FALSE в противном случае (if then else использовать нельзя)

Показать ответ
Ответ:
kovalvladislavoxx9e6
kovalvladislavoxx9e6
28.06.2021 19:14

Не знаю можно ли считать ноль, как "мінімальне додатнє", потому не включала

Объяснение:

#include<iostream>

using namespace std;

int main()

{

int l[15];

double min=0,max=0;

for(int i=0;i<15;i++)

{

   cin>>l[i];

   if(l[i]>0&&l[i]<min&&min!=0)

       min=l[i];

       if(min==0&&l[i]>0)

           min=l[i];

   if(l[i]<0&&l[i]>max&&max!=0)

       max=l[i];

       if(max==0&&l[i]<0)

           max=l[i];

}

sort(l,l+15);

cout<<min<<" "<<max<<endl;

cout<<min/max<<endl;

for(int i=14;i>=0;i--)

   cout<<l[i]<<" ";

   return 0;

}

0,0(0 оценок)
Ответ:
nk291726
nk291726
26.07.2022 10:24
Правильный ответ: 7
Ты из пункта А в пункт B едешь 2км.
Из B в пункт E 5км.

То есть куда тебе нужно из серой клетки попасть в другую серую. Например из А в пункт B, ты уже проехал 2км. Далее смотришь по горизонтали куда можно поехать. Ты видишь 3км (в столбике С) и 5км (в столбике E). Например выбираешь С и спускаешь на серую клетку. Далее от неё смотришь 6 (столбик D) и 10 (столбик E). Дальше так же выбираешь и спускаешься, но это я на пример показал длинный путь. Самый кратчайший я написал под правильным ответом.
Надеюсь понятно объяснил, если что пиши в комментариях или в сообщения.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота