В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
aizhanashoznweb
aizhanashoznweb
15.02.2022 18:49 •  Информатика

Напишите программу которая заполняет массив случайными целыми положительными отрицательными или 0 числами и выводит их на экран Понятно и качественно!!​

Показать ответ
Ответ:
bolt13222313
bolt13222313
30.12.2020 17:11

const

 n = 25;

 

var

 a: array[1..n] of integer;

 k0, k, i, s: integer;

 p: real;

 

begin

 s := 0;

 p := 1;

 k := 0;

 k0 := 0;

 for i := 1 to n do

 begin

   a[i] := -n div 2 + random(n);

   Write(a[i]:4);

   if a[i] = 0 then

     inc(k0);

   if a[i] > 0 then

     s := s + a[i];

   if a[i] < 0 then

   begin

     p := p * a[i];

     inc(k);

   end;

 end;

 WriteLn;

 Writeln('Сумма: ', s);

 Writeln('Количество 0: ', k0);

 if k <> 0 then

   Writeln('Произведение: ', p)

 else

   Writeln('Нет таких чисел. ')

end.

Объяснение:

0,0(0 оценок)
Ответ:
sabina1705
sabina1705
21.03.2023 11:11

Поставь мне 5 звёзд и лучший ответ :D

1.

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

   long long a, b;

   cin >> a >> b;

   cout << a*b << " " << (a+b)*2 << " " << sqrt(a*a + b*b) << endl;

   return 0;

}

2.

#include <iostream>

using namespace std;

int main()

{

   long long a, b, c;

   cin >> a >> b >> c;

   if(a == b || a == c || b == c)

       cout << "YES" << endl;

   else

       cout << "NO" << endl;

   return 0;

}

3.

#include <iostream>

using namespace std;

int main()

{

   int a;

   cin >> a;

   if(a <= 3)

       cout << "low" << endl;

   else

       if(a <= 6)

       cout << "medium" << endl;

   else

       if(a <= 9)

       cout << "prehigh" << endl;

   else

       cout << "high" << endl;

   return 0;

}

4.

#include <iostream>

using namespace std;

int main()

{

   long long a;

   cin >> a;

   if(a/10%10 > a/1000)

       cout << "YES" << endl;

   else

       cout << "NO" << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота