В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
сартоваа
сартоваа
02.08.2020 09:29 •  Информатика

Напишите программу, которая заполняет массив первыми N натуральными числами в обратном порядке (начиная с последнего) и выводит его.

Входные данные

Входная строка содержит размер массива N . Гарантируется, что 0 < N ≤ 10000 .

Выходные данные

Программа должна вывести содержимое массива: N последовательных натуральных чисел от N до 1 в обратном порядке.

пример
входные данные
5
выходные данные
5 4 3 2 1​

Показать ответ
Ответ:
rostislav2017
rostislav2017
29.04.2020 12:30

#include <iostream>

#include <cmath>

#include <algorithm>

#pragma GCC optimize("Ofast")

#define ll long long

#define ld long double

using namespace std;

signed main() {

  ll n;

  cin >> n;

  while(n--)

      cout << n+1 << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота