В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Санёк1616
Санёк1616
24.05.2020 16:26 •  Информатика

Напишите программу, которая заполняет массив из n элементов членами арифметической прогрессии с начальным значением x и разностью d . входные данные входная строка содержит три целых числа: начальное значение x , разность d и размер массива n , разделённые пробелом. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести содержимое массива: n первых членов арифметической прогрессии с начальным значением x и разностью d . примеры входные данные 8 4 5 выходные данные 8 12 16 20 24

Показать ответ
Ответ:
MOJH
MOJH
10.09.2020 07:24
#include <iostream>  
#include <vector>  
using namespace std;
int main()
{
int x,d,n;
cin >>x>>d>> n;
vector <int> v(n);
v[0] = x;
for (int i = 1;i<n;i++)
{
 v[i] = v[i - 1] + d;
}
for (int i = 0; i < n; i++)
{
 cout<<v[i]<<' ';
}
 return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота