В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
abrikosikhii
abrikosikhii
11.11.2020 11:57 •  Информатика

Напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [100; 200] и находит в нём пару соседних элементов, сумма которых минимальна. На питон

Показать ответ
Ответ:
Руслантопчик
Руслантопчик
04.03.2021 18:39

var a:array[1..20] of integer;

i,min,ind:integer;

begin  

randomize;

for i:=1 to 20 do begin

a[i]:=random(100)+100;

write(a[i]:4);

end;

writeln;

min:=a[1]+a[2];

for i:=2 to 19 do

if a[i]+a[i+1]<min then  

begin  

min:=a[i]+a[i+1];

ind:=i;

end;

write('Сумма минимальна между ',ind,' и ', ind+1, ' элементом');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота