В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Якрутой111
Якрутой111
26.04.2022 23:10 •  Информатика

Напишите программу которая выводит случайное число в диапазоне от a до b.После этого вводится еще одно вещественное число. Выведите отдельно целую часть и дробную часть произведения случайного целого числа на введенное вещественное

Показать ответ
Ответ:
sashgrts
sashgrts
23.04.2020 01:30

var a, b: real; i: integer;

begin  

randomize;  

readln(a,b);  

for i:= 1 to 5 do    

write((Random()*(b-a)+a):0:3, ' ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота