В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lox53
lox53
13.08.2020 14:20 •  Информатика

Напишите программу, которая выводит решение ребуса ЖУК*ЕЖ=. Одинаковым буквам соответствуют одинаковые цифры. Разным буквам соответствуют разные цифры. Числа не могут начинаться с нуля. В выводе между цифрами и знаками должны отсутствовать пробелы.
ПИТОН

Показать ответ
Ответ:
Elbek11ee
Elbek11ee
23.01.2021 08:43

import random

a = [0] * 4  

for i in range(4):  

   a[i] = [0] * 4

mi = 1

mj = 1

print("Матрица A:")

for i in range (4):

   for j in range (4):

       a[i][j] = random.randint(10,99)

       if a[i][j]>a[mi][mj]:

           mi = i

           mj = j

       print("%3d" % (a[i][j]),end="")

   print()

print("Максимум: A[{0},{1}] = {2}".format(mi+1,mj+1,a[mi][mj]))

Объяснение:

Создаём матрицу заполненную 0

Задаём начальные значения максимальных индексов

Заполняем матрицу случайными числами, ищем максимальные индексы и выводим элементы на экран

Выводим максимальные индексы и значение элемента


Задачи «В»: Напишите программу, которая заполняет матрицуслучайными числами и находит максимальныйэл
0,0(0 оценок)
Ответ:
Student9923
Student9923
19.12.2020 02:09
Class OftenChar{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in);
  String string = in.nextLine(); char chars[] = new char[4];
  chars[0] = in.nextLine().charAt(0); chars[2] = in.nextLine().charAt(0);
  for(int sChar = 0; sChar<string.length(); sChar++)
   if(string.charAt(sChar)==chars[0])chars[1]++;
   else if(string.charAt(sChar)==chars[2])chars[3]++;
  System.out.print("\n"+(chars[1]==chars[3]?chars[0]+""+chars[2]:chars[1]>chars[3]?chars[0]:chars[2]));
 }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота