В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
GoldenKookieBunny
GoldenKookieBunny
29.03.2020 20:42 •  Информатика

Напишите программу, которая выводит на экран: - Did Joffrey agree?
- He did. He also said "I love using \n".
При этом программа использует только один console.log(), но результат на экране должен выглядеть в точности, как показано выше.
говорю сразу это JS-JAVASCRIPT

Показать ответ
Ответ:
deulinslava26
deulinslava26
25.01.2022 23:14

ответ:

#include "stdafx.h"

#include

using namespace std;

struct complex // структура "хранения" комплексного числа

{ float re; // действительная часть

float im; // мнимая часть

};

void print( char * txt, complex x) // вывод комплексного числа

{

printf("%s=(%f,%fi)", txt, x.re, x.im);

return;

};

complex new_complex(float a, float b) // задать значение комплексному числу

{ complex temp;

temp.re=a;

temp.im=b;

return temp;

};

complex plus_complex(complex a, complex b) // сложить два комплексных чисел

{ complex temp;

temp.re=a.re+b.re;

temp.im=a.im+b.im;

return temp;

}

int main() // простая тестовая программа

{

complex z;

printf( "vvedite re и im 1 chisla: ");

cin > > z.re > > z.im;

print( "z", z); printf("\n");

complex q;

printf( "vvedite re и im 2 chisla: ");

cin > > q.re > > q.im;

print("q", q); printf("\n");

complex sum;

sum=plus_complex(z,q);

print("q+z", sum); printf("\n");

return 0;

}

0

0,0(0 оценок)
Ответ:
20jeka
20jeka
30.11.2022 07:14

N = int(input('Введите N (строки): '))

M = int(input('Введите M (столбцы): '))

array_1 = []

array_2 = []

array_3 = []

el = 0

for i in range(N):

   a = []

   if M % 2 == 0 and i > 0:

       if el == 0:

           el = 1

       else:

           el = 0

   for _ in range(M):

       a.append(el)

       if el == 0:

           el = 1

       else:

           el = 0

   array_1.append(a)

print('Задание 1.')

for row in array_1:

   for el in row:

       print(el, end = ' ')

   print()

for i in range(N):

   a = []

   for j in range(N):

       if j > i:

           a.append(0)

       else:

           a.append(1)

   array_2.append(a)

print()

print('Задание 2.')

for row in array_2:

   for el in row:

       print(el, end = ' ')

   print()

           

for i in range(N):

   a = []

   for j in range(N):

       if j < N - i - 1:

           a.append(0)

       else:

           a.append(1)

   array_3.append(a)

print()

print('Задание 3.')

for row in array_3:

   for el in row:

       print(el, end = ' ')

   print()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота