В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
karinayackupow
karinayackupow
21.04.2023 02:36 •  Информатика

Напишите программу, которая выведет номера всех лунок в гольфе, в которые нужно попасть, чтобы выиграть битву. Определяется это так. Нужно найти самую короткую из двух введенных строк, ее длина даст нам начальное число. Тогда длина оставшейся строки даст конечное число. А шаг – это число, введенное последним. Формат ввода
Вводятся две строки и число.

Формат вывода
Вывести все числа в диапазоне от длины короткой строки до длины длинной строки (не включая) с шагом, равным числу.

Пример 1
Ввод Вывод
Bilbo will do without a real bed and Breakfast.
Bilbo, you're a fool, you've got yourself into this business of your own free will.
3 47 50 53 56 59 62 65 68 71 74 77 80

Показать ответ
Ответ:
anna992
anna992
27.11.2021 10:30

start = input('Введите первую строку: ')

stop = input('Введите вторую строку: ')

num = int(input('Введите число: '))

if len(start) > len(stop):

   start, stop = stop, start

for i in range(len(start), len(stop), num):

   print(i)

Объяснение:

На Python

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота