В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Нурлы11
Нурлы11
01.12.2020 18:44 •  Информатика

Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером k и заканчивая элементом с номером m(включительно).

Показать ответ
Ответ:
Лерок228
Лерок228
07.07.2020 13:14
Var
  i,k,m,j:integer;
  a,b:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(50);
  write(a[i]:3);
  end;
writeln;
write('Введите k и m: ');
readln(k,m);
j:=m;
for i:=k to m do
  begin
  b[j]:=a[i];
  j:=j-1;
  end;
for i:=k to m do  a[i]:=b[i];
writeln('Измененный массив:');
for i:=1 to 10 do  write(a[i]:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота