В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
2525008
2525008
29.12.2020 16:41 •  Информатика

Напишите программу которая выделяе в другой массив все элементы исходного массива,которые встречаются более одного раза,с++,не писать свой код,а изменить мой, учтите что тесты могут быть 5
1 1 1 1 1
И тогда программа должна вывести лишь одну единицу
5
1 2 2 1 3
Вывод
1 2


Напишите программу которая выделяе в другой массив все элементы исходного массива,которые встречаютс

Показать ответ
Ответ:
Гульшат11111111
Гульшат11111111
21.01.2022 08:40

ответ в прикрепленном файле.

0,0(0 оценок)
Ответ:
NikolaAdamova
NikolaAdamova
21.01.2022 08:40

Резюмирую:

1) Использование того, чего не понимаешь (6-8 строки)

2) Решение за O(N^2) при ограничении N < 10^5, что очень плохо

3) Нет проверки на выход за границы выделенной памяти (20, 22 строки)

4) Абсолютно неверная идея алгоритма: сравнивать только соседние элементы, да и еще и непонятно зачем делать во вложенном цикле + неверное написание тела цикла фор: полное непонимание того, как он работает и что делает

5) Нет проверки на то, использовали мы конкретное число уже или нет

Итог: полностью неверное решение, которое надо не менять, а стирать и переделывать.

Возможное решение на сотку:

#include <iostream>

#include <vector>

#include <map>

using namespace std;

signed main() {

   map<int, int> cnt;

   int n;

   cin >> n;

   vector<int> a(n), res;

   for(auto &i: a){

       cin >> i;

       cnt[i]++;

   }

   for(auto &i: a){

       if(cnt[i] > 1) res.push_back(i);

       cnt[i] = 0;

   }

   if(res.empty()) cout << 0;

   else for(auto &i: res) cout << i << " ";

}

P.S. Если что непонятно, то спрашивай - распишу поминутно кто где того самого

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота