В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
VolkovaI
VolkovaI
08.11.2021 17:02 •  Информатика

Напишите программу, которая вычисляет сумму элементов последовательности целых чисел, поданных не её вход. Ввод заканчивается числом 0. ---Входные данные---
Во входных строках записаны целые числа, по одному в каждой строке. В последней строке записано число 0.

---Выходные данные---
Программа должна вывести одно число – сумму всех элементов последовательности.
ПРИМЕР
Ввод
1
2
3
0
Вывод
6
Ввод
-1
-2
-3
-4
0
Вывод
-10
Желательно на Питоне или Паскале с использованием РЕКУРСИИ(функции или процедуры)!

Показать ответ
Ответ:
рамзан010191271894
рамзан010191271894
07.01.2021 04:36

Задачи в 1 действие -_-

#include <iostream>

using namespace std;

int main()

{

   long long a, sum = 0;

   while(1)

   {

       cin >> a;

       if(a == 0)

           break;

       else

           sum+=a;

   }

   cout << sum << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота